Advanced search

Message boards : News : [dna] will be sending out test work units

1 · 2 · Next
Author Message
Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3038 - Posted: 13 Aug 2014, 0:49:59 UTC

It's taken a bit of work, but I've gotten the work generator able to send out work units (and it looks like they're crunching successfully at least on my end).

I'll probably sent out a few more small batches for testing tonight, and will get working on the validator next. The validator is going to take a bit more updating, because I need to make sure it's assigning credits correctly to the sub projects, which is going to be all custom code.

lionelc
Send message
Joined: 20 Dec 12
Posts: 9
Combined Credit: 150,433
DNA@Home: 100,173
SubsetSum@Home: 50,163
Wildlife@Home: 97
Wildlife@Home Watched: 1,654s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

    
Message 3044 - Posted: 13 Aug 2014, 6:06:10 UTC - in response to Message 3038.

Travis

all the tasks are stopped durring calculation with following error message :

</stderr_txt>
<message>
upload failure: <file_xfer_error>
<file_name>gibbs_test_run_4_96_0_3_0</file_name>
<error_code>-161 (not found)</error_code>
</file_xfer_error>

[VENETO] boboviz
Send message
Joined: 10 Aug 14
Posts: 98
Combined Credit: 387,515
DNA@Home: 184,990
SubsetSum@Home: 1,636
Wildlife@Home: 200,890
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

    
Message 3045 - Posted: 13 Aug 2014, 6:27:18 UTC - in response to Message 3044.

all the tasks are stopped durring calculation with following error message :

</stderr_txt>
<message>
upload failure: <file_xfer_error>
<file_name>gibbs_test_run_4_96_0_3_0</file_name>
<error_code>-161 (not found)</error_code>
</file_xfer_error>


Same here, after 3 minutes of calculation all errors

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3046 - Posted: 13 Aug 2014, 6:36:44 UTC - in response to Message 3045.

all the tasks are stopped durring calculation with following error message :



upload failure:
gibbs_test_run_4_96_0_3_0
-161 (not found)


Same here, after 3 minutes of calculation all errors


Thanks, I had updated the result xml template for the work units, and it looks like I needed to add an optional flag for the optional output file (I though upload when present did that but it turns out it does not).

gibbs_test_run_6 should fix this.

lionelc
Send message
Joined: 20 Dec 12
Posts: 9
Combined Credit: 150,433
DNA@Home: 100,173
SubsetSum@Home: 50,163
Wildlife@Home: 97
Wildlife@Home Watched: 1,654s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

    
Message 3047 - Posted: 13 Aug 2014, 6:46:20 UTC - in response to Message 3046.

"gibbs_test_run_6 " tasks are completing (validation pending)


seems ok


thanks

P . P . L .
Send message
Joined: 10 Aug 14
Posts: 59
Combined Credit: 336,654
DNA@Home: 336,605
SubsetSum@Home: 0
Wildlife@Home: 49
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

  
Message 3048 - Posted: 13 Aug 2014, 6:47:53 UTC

Hi.

Only got one so far and it erred, like so.

<core_client_version>7.2.42</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/volunteer.cs.und.edu_csg/Gibbs_i686-pc-linux-gnu: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

</stderr_txt>
]]>
____________

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3049 - Posted: 13 Aug 2014, 7:01:56 UTC - in response to Message 3048.
Last modified: 13 Aug 2014, 7:04:57 UTC

Hi.

Only got one so far and it erred, like so.

7.2.42

process exited with code 127 (0x7f, -129)


../../projects/volunteer.cs.und.edu_csg/Gibbs_i686-pc-linux-gnu: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory


]]>


I can see about getting the binaries compiled with a static libc++, but that might take a little while . An quick option for you would be just to upgrade (or install) libc++.

From a terminal:

apt-get install lib32stdc++6
or
apt-get install lib64stdc++6

depending on if your machine is 32 or 64 bit.

P . P . L .
Send message
Joined: 10 Aug 14
Posts: 59
Combined Credit: 336,654
DNA@Home: 336,605
SubsetSum@Home: 0
Wildlife@Home: 49
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

  
Message 3050 - Posted: 13 Aug 2014, 7:48:56 UTC
Last modified: 13 Aug 2014, 8:03:11 UTC

Hi Travis.

Strange that it was on a new install of 14.04lts x64.

Anyway I found this I'll see if it works, it might help someone else.

sudo apt-get install gcc-4.7-multilib

It's for x32 libs on Ubuntu 14.04lts.

Edit / I just got 25 w.u.'s to try since I updated the libs on that rig, I'll see how it goes now.

thanks.
____________

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3058 - Posted: 13 Aug 2014, 18:39:12 UTC - in response to Message 3050.

Hi Travis.

Strange that it was on a new install of 14.04lts x64.

Anyway I found this I'll see if it works, it might help someone else.

sudo apt-get install gcc-4.7-multilib

It's for x32 libs on Ubuntu 14.04lts.

Edit / I just got 25 w.u.'s to try since I updated the libs on that rig, I'll see how it goes now.

thanks.


Just sent out a bunch more WUs for testing, hopefully you can grab some! If you don't send me an email and I'll make another batch.

[VENETO] boboviz
Send message
Joined: 10 Aug 14
Posts: 98
Combined Credit: 387,515
DNA@Home: 184,990
SubsetSum@Home: 1,636
Wildlife@Home: 200,890
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

    
Message 3061 - Posted: 13 Aug 2014, 19:06:49 UTC - in response to Message 3058.

Just sent out a bunch more WUs for testing


Seems to be ok on windows
But no file results to upload. Is this normal??

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3062 - Posted: 13 Aug 2014, 19:39:34 UTC - in response to Message 3061.
Last modified: 13 Aug 2014, 19:41:54 UTC

Just sent out a bunch more WUs for testing


Seems to be ok on windows
But no file results to upload. Is this normal??


Yes, I actually noticed a bug. Basically DNA@Home sends out work units in chains, and the first few work units in the chain don't need an output file.

Once the assimilator is back up and running (and generating new WUs based on ones validated) the new WUs will eventually start generating an output file.

I don't know if you know much about Markov Chains, but what DNA@Home does is basically a modified version of markov chains which quasi-randomly select areas of DNA to sample from to find transcription factors. Over time, the samples start to model how likely that site is to be a transcription factor.

So what we need to do is first make a bunch of random selections to get rid of any bias from our initial selection (as each next selection is based on the previous). After that we can start collecting the samples and take a look at what we've found, i.e., did we discover any new transcription factors?

P . P . L .
Send message
Joined: 10 Aug 14
Posts: 59
Combined Credit: 336,654
DNA@Home: 336,605
SubsetSum@Home: 0
Wildlife@Home: 49
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

  
Message 3063 - Posted: 13 Aug 2014, 21:17:13 UTC

Hi Travis.

Those 25 wu's run o.k. by the look of it, there was no output file but I see that's normal for those.

There still awaiting validation.
____________

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3066 - Posted: 13 Aug 2014, 21:27:52 UTC - in response to Message 3063.
Last modified: 13 Aug 2014, 21:28:26 UTC

Hi Travis.

Those 25 wu's run o.k. by the look of it, there was no output file but I see that's normal for those.

There still awaiting validation.


Yup! Working on the validator right now. Barring anything catastrophic I might have the validator and assimilator upgraded and ready to go by the end of the night.

kashi
Send message
Joined: 24 Apr 12
Posts: 7
Combined Credit: 35,246,297
DNA@Home: 652,497
SubsetSum@Home: 36,047
Wildlife@Home: 34,557,753
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

      
Message 3067 - Posted: 13 Aug 2014, 22:03:59 UTC
Last modified: 13 Aug 2014, 22:05:56 UTC

I did 308 DNA@Home tasks sent out by the CSG server, 211 are pending, 97 were from the error batch. None have validated yet.

However 370 credits have suddenly appeared in my account under Wildlife@ Home, where I previously had zero credit as I've never done any Wildlife@Home work.

I watched a Wildlife@Home video recently for a while to be able to post here, but I didn't answer any questions about it. Was 370 credits for that video I watched? I'm not concerned about the 370 credits just wondering where they came from.

lionelc
Send message
Joined: 20 Dec 12
Posts: 9
Combined Credit: 150,433
DNA@Home: 100,173
SubsetSum@Home: 50,163
Wildlife@Home: 97
Wildlife@Home Watched: 1,654s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

    
Message 3068 - Posted: 13 Aug 2014, 22:28:10 UTC - in response to Message 3067.

nearly the same for me :

I had only one validated task for Wildlife@Home with 75 credits

Now my account shows Wildlife@Home total credit 97
I remember that yesterday and even this morning (Europe time) it showed 75

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3070 - Posted: 13 Aug 2014, 22:29:42 UTC - in response to Message 3067.

I did 308 DNA@Home tasks sent out by the CSG server, 211 are pending, 97 were from the error batch. None have validated yet.

However 370 credits have suddenly appeared in my account under Wildlife@ Home, where I previously had zero credit as I've never done any Wildlife@Home work.

I watched a Wildlife@Home video recently for a while to be able to post here, but I didn't answer any questions about it. Was 370 credits for that video I watched? I'm not concerned about the 370 credits just wondering where they came from.


Hmm, it looks like some things went weird while I've been working on the new dna@home validator. Let me look into it.

Profile PDW
Send message
Joined: 10 Aug 14
Posts: 26
Combined Credit: 123,696,648
DNA@Home: 2,517,852
SubsetSum@Home: 5,000,796
Wildlife@Home: 116,178,000
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 31
Images Observed: 14

          
Message 3071 - Posted: 13 Aug 2014, 22:31:50 UTC

I've also managed to accumulate some Wildlife credit despite watching 0 seconds with 0 valid events !

Am also interested how you export stats for all those people who might not have a team set in CSG but did in DNA (or SubsetSum/Wildlife).

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3073 - Posted: 13 Aug 2014, 22:35:01 UTC - in response to Message 3070.

Found the problem, so I had run the validator in testing mode a few times and thought it was not granting credit (because it was supposedly not updating the database). Turns out was granting credit, but not updating the work unit and result tables.

In the meantime I had made columns in the database for wildlife@home credit and copied things over in there. So it looks like some of the DNA@Home credit that got awarded leaked over there.

Shouldn't happen any more as it was a one time move of things around in the database. You both happened to be some of the lucky couple people who got some bonus credit due to the validator mix up. :P

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 3074 - Posted: 13 Aug 2014, 22:35:36 UTC - in response to Message 3071.

I've also managed to accumulate some Wildlife credit despite watching 0 seconds with 0 valid events !

Am also interested how you export stats for all those people who might not have a team set in CSG but did in DNA (or SubsetSum/Wildlife).


I think the only way I can make this work is that credit will be granted for the CSG team only.

Profile PDW
Send message
Joined: 10 Aug 14
Posts: 26
Combined Credit: 123,696,648
DNA@Home: 2,517,852
SubsetSum@Home: 5,000,796
Wildlife@Home: 116,178,000
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 31
Images Observed: 14

          
Message 3076 - Posted: 13 Aug 2014, 22:44:22 UTC - in response to Message 3074.
Last modified: 13 Aug 2014, 22:48:11 UTC

I've also managed to accumulate some Wildlife credit despite watching 0 seconds with 0 valid events !

Am also interested how you export stats for all those people who might not have a team set in CSG but did in DNA (or SubsetSum/Wildlife).


I think the only way I can make this work is that credit will be granted for the CSG team only.


So will all the people with pre-CSG credit lose their team points if they never move over, or move over but never set a team ?

Edit: Oh, and thanks for the free points :)

1 · 2 · Next
Post to thread

Message boards : News : [dna] will be sending out test work units