Advanced search

Message boards : News : slow video streaming

Author Message
Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 22
Images Observed: 774

              
Message 1979 - Posted: 27 Oct 2013, 16:03:58 UTC
Last modified: 27 Oct 2013, 17:01:17 UTC

I think we might have found the culprit for videos that are streaming slowly.

I made some changes such that if the full video duration was less than the streaming video size (5, 10, 20 minutes) then i just used the video files generated for BOINC work units (instead of creating a copy of them for streaming). It looks like the settings for generating those videos were resulting in videos a lot larger than the ones used for streaming.

I'd like to check this. For the videos that are playing slowly, are they all coming videos in the watermarked directory? Their source would look something like this:

http://wildlife.und.edu//share/wildlife/watermarked/oil_development/2012/
sharptailed_grouse/Blaisdell/150.7601_hatch/5-15-12_1507601/CH00_20120517_005936MN.mp4

as opposed to:

http://wildlife.und.edu//share/wildlife/streaming_2/oil_development/2012/
sharptailed_grouse/Blaisdell/150.7601_hatch/5-15-12_1507601/CH00_20120517_005936MN.mp4

Where is where most streaming videos should be coming from.

hiigaran
Avatar
Send message
Joined: 25 Sep 13
Posts: 131
Combined Credit: 0
DNA@Home: 0
SubsetSum@Home: 0
Wildlife@Home: 0
Wildlife@Home Watched: 3,895,814s
Wildlife@Home Events: 2
Climate Tweets: 0
Images Observed: 0

  
Message 1982 - Posted: 27 Oct 2013, 17:03:27 UTC

So far I've been getting nothing but streaming_2 videos, mixed with fast and slow performance.

Profile STE\/E
Avatar
Send message
Joined: 5 Apr 13
Posts: 416
Combined Credit: 29,783,819
DNA@Home: 2,634,206
SubsetSum@Home: 735,231
Wildlife@Home: 26,414,382
Wildlife@Home Watched: 53,380,530s
Wildlife@Home Events: 9,349
Climate Tweets: 0
Images Observed: 0

          
Message 2083 - Posted: 4 Nov 2013, 13:21:44 UTC

All Video's no matter the Length seem to be really herky jerky when loading for the last 3 day's or so ...

hiigaran
Avatar
Send message
Joined: 25 Sep 13
Posts: 131
Combined Credit: 0
DNA@Home: 0
SubsetSum@Home: 0
Wildlife@Home: 0
Wildlife@Home Watched: 3,895,814s
Wildlife@Home Events: 2
Climate Tweets: 0
Images Observed: 0

  
Message 2229 - Posted: 23 Nov 2013, 23:53:15 UTC

I've noticed a pattern with the remaining few videos that stream slowly. If you look at the video's name/identifier/thing (eg: 148.043 - CH00_20120612_152109MN_CHILD0), you'll notice the bit right at the end that says CHILD, followed by a number. So far, all videos I have seen with slow streaming do not have CHILDX in their names. However, I've also noticed that it's not every single 'childless' (for lack of a better word) video. Specifically, all videos that are childless and have a non standard video length (ie, not a rounded number, like exactly 10 or 20 minutes, such as 15:46) have this issue.

Profile Defender
Avatar
Send message
Joined: 4 May 13
Posts: 103
Combined Credit: 1,607,715
DNA@Home: 26,301
SubsetSum@Home: 21,008
Wildlife@Home: 1,560,405
Wildlife@Home Watched: 1,089,206s
Wildlife@Home Events: 343
Climate Tweets: 4
Images Observed: 8

          
Message 2232 - Posted: 24 Nov 2013, 7:14:31 UTC - in response to Message 2229.

Well done, inspector! ;-)
____________
Proud member of SETI.Germany

hiigaran
Avatar
Send message
Joined: 25 Sep 13
Posts: 131
Combined Credit: 0
DNA@Home: 0
SubsetSum@Home: 0
Wildlife@Home: 0
Wildlife@Home Watched: 3,895,814s
Wildlife@Home Events: 2
Climate Tweets: 0
Images Observed: 0

  
Message 2234 - Posted: 24 Nov 2013, 10:07:54 UTC

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 22
Images Observed: 774

              
Message 2246 - Posted: 26 Nov 2013, 17:17:10 UTC - in response to Message 2229.

I've noticed a pattern with the remaining few videos that stream slowly. If you look at the video's name/identifier/thing (eg: 148.043 - CH00_20120612_152109MN_CHILD0), you'll notice the bit right at the end that says CHILD, followed by a number. So far, all videos I have seen with slow streaming do not have CHILDX in their names. However, I've also noticed that it's not every single 'childless' (for lack of a better word) video. Specifically, all videos that are childless and have a non standard video length (ie, not a rounded number, like exactly 10 or 20 minutes, such as 15:46) have this issue.


Yeah I thought that was the problem. I'll be working on getting these videos re-converted. It should also help with the download sizes for work units.


Post to thread

Message boards : News : slow video streaming