Advanced search

Message boards : News : [wildlife] Background Subtraction Workunits

1 · 2 · Next
Author Message
Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5039 - Posted: 24 Mar 2015, 18:02:30 UTC
Last modified: 24 Mar 2015, 18:02:38 UTC

Hi everyone!

I will be testing some work units today for one of the new Wildlife@Home programs (wildlife_bgsub). The first few jobs sent out will just be tests for 64 bit linux machines and will likely have a few errors but hopefully I can get them fixed asap.

Thanks!
____________
--
Kyle

Michal Kindura
Send message
Joined: 28 Apr 13
Posts: 123
Combined Credit: 81,669,569
DNA@Home: 253,257
SubsetSum@Home: 1,127,118
Wildlife@Home: 80,289,195
Wildlife@Home Watched: 38,247,903s
Wildlife@Home Events: 12,091
Climate Tweets: 4
Images Observed: 3,195

            
Message 5040 - Posted: 25 Mar 2015, 9:42:37 UTC

Hi,
I noticed too many failures after 1 second of computing. Sometimes immediately after start.

Profile Conan
Avatar
Send message
Joined: 13 Apr 12
Posts: 151
Combined Credit: 47,672,899
DNA@Home: 399,792
SubsetSum@Home: 1,448,876
Wildlife@Home: 45,824,231
Wildlife@Home Watched: 70,910s
Wildlife@Home Events: 0
Climate Tweets: 412
Images Observed: 0

          
Message 5041 - Posted: 25 Mar 2015, 12:01:07 UTC

All have the following error for me


<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/volunteer.cs.und.edu_csg/wildlife_bgsub_0.03_x86_64-pc-linux-gnu: error while loading shared libraries: libva-x11.so.1: cannot open shared object file: No such file or directory

</stderr_txt>
]]>

See this example

Conan
____________

Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5042 - Posted: 25 Mar 2015, 14:42:07 UTC

I added the missing libraries to to the downloads. Those errors should go away now. Thanks for your quick feedback!
____________
--
Kyle

Profile Conan
Avatar
Send message
Joined: 13 Apr 12
Posts: 151
Combined Credit: 47,672,899
DNA@Home: 399,792
SubsetSum@Home: 1,448,876
Wildlife@Home: 45,824,231
Wildlife@Home Watched: 70,910s
Wildlife@Home Events: 0
Climate Tweets: 412
Images Observed: 0

          
Message 5044 - Posted: 26 Mar 2015, 10:23:12 UTC
Last modified: 26 Mar 2015, 10:23:55 UTC

I did have one of the version .03 work units complete but was unable to be validated due to all the other work units failing.

See this Result

Also the new version 0.05 now fails with this error

See here


<message>
process exited with code 1 (0x1, -255)
</message>
<stderr_txt>
../../projects/volunteer.cs.und.edu_csg/wildlife_bgsub_0.05_x86_64-pc-linux-gnu: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by ./libavutil.so.54)

</stderr_txt>

Conan
____________

Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5067 - Posted: 1 Apr 2015, 19:23:15 UTC

Looking into this a little more it seems the binaries I am using link against some new objects in GLIBC. I am working on restricting this app to kernel versions newer than 3.11. This should resolve the GLIBC errors however you will not receive work if your kernel is older than version 3.11.

In the latest batch of work I sent out I also noticed some work units exceeding the specified disk limit. I will double check the value I provided for this and and send out a new batch of work once that is confirmed as well.

Thanks for the patience!
____________
--
Kyle

Profile Conan
Avatar
Send message
Joined: 13 Apr 12
Posts: 151
Combined Credit: 47,672,899
DNA@Home: 399,792
SubsetSum@Home: 1,448,876
Wildlife@Home: 45,824,231
Wildlife@Home Watched: 70,910s
Wildlife@Home Events: 0
Climate Tweets: 412
Images Observed: 0

          
Message 5072 - Posted: 2 Apr 2015, 10:58:17 UTC - in response to Message 5067.

[quote]Looking into this a little more it seems the binaries I am using link against some new objects in GLIBC. I am working on restricting this app to kernel versions newer than 3.11. This should resolve the GLIBC errors however you will not receive work if your kernel is older than version 3.11.


Thanks for the patience![/quote]

Well that puts me out as I have 3.6 (Fedora 16), never mind I can still do DNA and SubSetSum.

Conan
____________

Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5078 - Posted: 3 Apr 2015, 4:16:10 UTC - in response to Message 5072.

Looks like the work units are coming back successfully. I started the validator and generated work for all of the grouse video. There are about 40,000 jobs ready for processing. I will start the tern and plover data over the coming days.

I also plan on integrating results form these videos into the video watching interface to add some useful data to for the watchers.
____________
--
Kyle

Profile Andreas38871
Send message
Joined: 6 May 13
Posts: 11
Combined Credit: 2,301,926
DNA@Home: 509,006
SubsetSum@Home: 365,144
Wildlife@Home: 1,427,776
Wildlife@Home Watched: 1,261,458s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

        
Message 5080 - Posted: 3 Apr 2015, 8:22:46 UTC

Are you planning a Windows application? When might thus be expected.
Andreas

Profile [AF>Amis des Lapins] Oncle Bob
Send message
Joined: 21 Apr 13
Posts: 7
Combined Credit: 32,102,790
DNA@Home: 2,250
SubsetSum@Home: 150,492
Wildlife@Home: 31,950,049
Wildlife@Home Watched: 64,860s
Wildlife@Home Events: 26
Climate Tweets: 56
Images Observed: 164

            
Message 5081 - Posted: 3 Apr 2015, 9:05:38 UTC
Last modified: 3 Apr 2015, 9:12:20 UTC

Hello,

I've received a few units, both on my Windows 7 64 bit Home (v. 0.02) and my Linux 64 bit.

Linux seems to work correctly but all Windows lead to error (0 second computing).

Edit : Example or error :

03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)

____________

Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5084 - Posted: 3 Apr 2015, 16:54:24 UTC - in response to Message 5081.
Last modified: 3 Apr 2015, 16:55:21 UTC

Hello,

I've received a few units, both on my Windows 7 64 bit Home (v. 0.02) and my Linux 64 bit.

Linux seems to work correctly but all Windows lead to error (0 second computing).

Edit : Example or error :

03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)
03/04/2015 10:38:49 | Citizen Science Grid | [error] Process creation failed: (unknown error) - error code 193 (0xc1)


Hi Oncle Bob,

This is a very strange error since this project doesn't actually have a windows version available right now. It appears that BOINC is sending your windows machine the 32 bit Linux binaries (which is why you are seeing the process creation failed). I have no idea why this is happening but I am looking into it and will report back here when I make some progress.


Are you planning a Windows application? When might thus be expected.
Andreas


Creating windows work units is definitely a goal but right now I am writing my thesis and don't foresee much time to work on those in the near future.
____________
--
Kyle

Michal Kindura
Send message
Joined: 28 Apr 13
Posts: 123
Combined Credit: 81,669,569
DNA@Home: 253,257
SubsetSum@Home: 1,127,118
Wildlife@Home: 80,289,195
Wildlife@Home Watched: 38,247,903s
Wildlife@Home Events: 12,091
Climate Tweets: 4
Images Observed: 3,195

            
Message 5085 - Posted: 3 Apr 2015, 21:49:50 UTC
Last modified: 3 Apr 2015, 22:03:46 UTC

Hi,
My WUs fails...


<core_client_version>7.0.28</core_client_version>
<![CDATA[
<message>
process exited with code 1 (0x1, -255)
</message>
<stderr_txt>
../../projects/volunteer.cs.und.edu_csg/wildlife_bgsub_0.07_x86_64-pc-linux-gnu__linux_min: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by ./libstdc++.so.6)

</stderr_txt>
]]>


Result ID link: http://volunteer.cs.und.edu/csg/result.php?resultid=3308361

EDIT: I have kernel version Linux 3.13.0-48-generic, Ubuntu 64 bit 12.04 (precise)

Michal Kindura
Send message
Joined: 28 Apr 13
Posts: 123
Combined Credit: 81,669,569
DNA@Home: 253,257
SubsetSum@Home: 1,127,118
Wildlife@Home: 80,289,195
Wildlife@Home Watched: 38,247,903s
Wildlife@Home Events: 12,091
Climate Tweets: 4
Images Observed: 3,195

            
Message 5090 - Posted: 4 Apr 2015, 1:32:34 UTC

I was looking for solution. I think that....

Ubuntu 12.04 LTS precise contains package libc6 in version 2.15, but required is 2.17 and newer. I tried to install this package manually, but I create a conflict between packages.

I didn't have courage for "force install". :)

My solution was install two virtual desktops with 64bit Ubuntu Trusty, which contains libc6 v. 2.19, compatible with your Video Background Subtractor apps.

My solution is very alternative and I don't know how effective it is. But it works. If it were possible to solve it natively, it would be good. I don't know how many users are affected.

Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5091 - Posted: 4 Apr 2015, 4:11:57 UTC - in response to Message 5090.
Last modified: 4 Apr 2015, 4:12:30 UTC

Hi Michal,

I checked some other results and it seems you are the only one to run into this issue so far. The binaries were build with 14.04 so you shouldn't see any problems on that VM.
____________
--
Kyle

Profile [AF>Amis des Lapins] Oncle Bob
Send message
Joined: 21 Apr 13
Posts: 7
Combined Credit: 32,102,790
DNA@Home: 2,250
SubsetSum@Home: 150,492
Wildlife@Home: 31,950,049
Wildlife@Home Watched: 64,860s
Wildlife@Home Events: 26
Climate Tweets: 56
Images Observed: 164

            
Message 5092 - Posted: 4 Apr 2015, 10:31:30 UTC

Less important thing : despite validated units, i'm still stuck to the the score I had a few days ago.

Besides, why do the units reward so few credits ?

Travis Desell
Volunteer moderator
Project administrator
Project developer
Project scientist
Send message
Joined: 16 Jan 12
Posts: 1813
Combined Credit: 23,514,257
DNA@Home: 293,563
SubsetSum@Home: 349,212
Wildlife@Home: 22,871,482
Wildlife@Home Watched: 212,926s
Wildlife@Home Events: 51
Climate Tweets: 21
Images Observed: 774

              
Message 5093 - Posted: 4 Apr 2015, 16:48:35 UTC - in response to Message 5092.

Less important thing : despite validated units, i'm still stuck to the the score I had a few days ago.

Besides, why do the units reward so few credits ?


Kyle might not have set the FLOPS right... I'll ask him.

M0CZY
Avatar
Send message
Joined: 8 Aug 13
Posts: 1
Combined Credit: 57,606
DNA@Home: 1,416
SubsetSum@Home: 3,293
Wildlife@Home: 52,896
Wildlife@Home Watched: 0s
Wildlife@Home Events: 0
Climate Tweets: 0
Images Observed: 0

  
Message 5095 - Posted: 5 Apr 2015, 7:24:34 UTC

Crikey, I'm not going to be able to keep these going for too much longer!
In only 12 hours I've used over 2GB of my 10GB monthly allowance.
____________
The biggest threat to public safety and security is not terrorism, it is Government abuse of authority.

Bitcoin Donations: 1Le52kWoLz42fjfappoBmyg73oyvejKBR3

Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5097 - Posted: 5 Apr 2015, 16:37:49 UTC - in response to Message 5092.

Less important thing : despite validated units, i'm still stuck to the the score I had a few days ago.

Besides, why do the units reward so few credits ?


I did have the credits incorrectly set for the validation. For now I removed the static scoring and am using the BOINC automatic score. Out of curiosity, where do you think you should be for credit/hours on this app?
____________
--
Kyle

Profile Steve Hawker*
Send message
Joined: 8 Apr 13
Posts: 134
Combined Credit: 829,896
DNA@Home: 11,932
SubsetSum@Home: 299,708
Wildlife@Home: 518,257
Wildlife@Home Watched: 5,541,577s
Wildlife@Home Events: 2,169
Climate Tweets: 8,645
Images Observed: 55

              
Message 5101 - Posted: 5 Apr 2015, 21:33:27 UTC - in response to Message 5097.

Less important thing : despite validated units, i'm still stuck to the the score I had a few days ago.

Besides, why do the units reward so few credits ?


I did have the credits incorrectly set for the validation. For now I removed the static scoring and am using the BOINC automatic score. Out of curiosity, where do you think you should be for credit/hours on this app?


Danger! Danger! Warning Will Robinson!!

uh-oh, sounds like CreditNew is here...

Kyle Goehner
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 17 Feb 13
Posts: 46
Combined Credit: 866,343
DNA@Home: 66,934
SubsetSum@Home: 205,422
Wildlife@Home: 593,987
Wildlife@Home Watched: 44,959s
Wildlife@Home Events: 3
Climate Tweets: 6
Images Observed: 9

        
Message 5104 - Posted: 6 Apr 2015, 3:22:39 UTC

I updated the workunits to give quite a bit more than they were originally credited for (no more CreditNew). I would still love to know where you feel the credit/hour rate should be for this project.

Thanks!
____________
--
Kyle

1 · 2 · Next
Post to thread

Message boards : News : [wildlife] Background Subtraction Workunits